Приветствуем, Гость! Регистрация

Linux и Intel HD 4000, тормоза
#1
Есть ноутбук с Intel i3 3110m. Внутри стоит Intel HD 4000. И оно тормозит. По крайней мере, в KDE. Случается это при запуске Firefox, или при включении эффектов. В других ОС (Windows 7 с её Aero, например) интеграшка ведёт себя нормально. Ну или я не замечал косяков. Переключение на glamor ситуацию не исправляет. Всякие энергосберегайки вроде как отключены. Они включены для дискретного радеона. Скроллинг в браузере ощутимо тормозит.
Код:
[font=monospace][color=#000000]user@G500 [/color][color=#18b218]~[/color][color=#000000]> glxinfo | grep OpenGL [/color]
[color=#ff5454]OpenGL[/color][color=#000000] vendor string: Intel Open Source Technology Center [/color]
[color=#ff5454]OpenGL[/color][color=#000000] renderer string: Mesa DRI Intel(R) HD Graphics 4000 (IVB GT2) [/color]
[color=#ff5454]OpenGL[/color][color=#000000] core profile version string: 4.2 (Core Profile) Mesa 20.3.3 [/color]
[color=#ff5454]OpenGL[/color][color=#000000] core profile shading language version string: 4.20 [/color]
[color=#ff5454]OpenGL[/color][color=#000000] core profile context flags: (none) [/color]
[color=#ff5454]OpenGL[/color][color=#000000] core profile profile mask: core profile [/color]
[color=#ff5454]OpenGL[/color][color=#000000] core profile extensions: [/color]
[color=#ff5454]OpenGL[/color][color=#000000] version string: 3.0 Mesa 20.3.3 [/color]
[color=#ff5454]OpenGL[/color][color=#000000] shading language version string: 1.30 [/color]
[color=#ff5454]OpenGL[/color][color=#000000] context flags: (none) [/color]
[color=#ff5454]OpenGL[/color][color=#000000] extensions: [/color]
[color=#ff5454]OpenGL[/color][color=#000000] ES profile version string: [/color][color=#ff5454]OpenGL[/color][color=#000000] ES 3.0 Mesa 20.3.3 [/color]
[color=#ff5454]OpenGL[/color][color=#000000] ES profile shading language version string: [/color][color=#ff5454]OpenGL[/color][color=#000000] ES GLSL ES 3.00 [/color]
[color=#ff5454]OpenGL[/color][color=#000000] ES profile extensions:[/color][/font]
OS - Fedora 33 с KDE.

UPD: на 1920x1080 происходят тормоза независимо от запущенных приложений.
It's time to kick gum and chew ass. And i'm all out of ass.
Ответ
#2
С glamor ситуация немного интереснее: если одновременно открыт Firefox и какое-нибудь другое приложение, то тормозит всё. Если закрыть приложение, то скроллинг в Firefox становится плавным.
It's time to kick gum and chew ass. And i'm all out of ass.
Ответ
#3
Вместо glamor можешь попробовать ещё sna и uxa.
Правила форума
[Новичкам] Как правильно задавать вопросы, чтобы Вам помогли

«Буду бить аккуратно, но сильно!» © Лёлик, х/ф «Бриллиантовая рука»
Ответ
#4
(09.02.2021 11:Feb)mord0d Написал: Вместо glamor можешь попробовать ещё sna и uxa.

С uxa не заводится (вроде как из-за этого не работала графика в FreeBSD, но это уже вне данной темы), sna вроде как и так по дефолту.
Заводится только с glamor. Ни uxa, ни sna не работают.
С modesetting вместо intel не работали. Сейчас работают, но толку нет.
It's time to kick gum and chew ass. And i'm all out of ass.
Ответ
#5
Судя по гуглу, тормоза возникают из-за EGL.
It's time to kick gum and chew ass. And i'm all out of ass.
Ответ
#6
(09.02.2021 11:Feb)ozz Написал: Судя по гуглу, тормоза возникают из-за EGL.

Я изначально это и предполагал (ещё в IRC), но как с этим бороться — без понятия.

Может ли быть такое, что MOZ_X11_EGL=1 по дефолту?

Попробуй добавить куда-нибудь unset MOZ_X11_EGL или MOZ_X11_EGL=0 (не знаю как Firefox обрабатывает эту переменную, потому попробуй оба варианта), где оно точно сработает (/etc/environment, или /etc/profile.d/...).
Правила форума
[Новичкам] Как правильно задавать вопросы, чтобы Вам помогли

«Буду бить аккуратно, но сильно!» © Лёлик, х/ф «Бриллиантовая рука»
Ответ
#7
(09.02.2021 14:Feb)mord0d Написал:
(09.02.2021 11:Feb)ozz Написал: Судя по гуглу, тормоза возникают из-за EGL.

Я изначально это и предполагал (ещё в IRC), но как с этим бороться — без понятия.

Может ли быть такое, что MOZ_X11_EGL=1 по дефолту?

Попробуй добавить куда-нибудь unset MOZ_X11_EGL или MOZ_X11_EGL=0 (не знаю как Firefox обрабатывает эту переменную, потому попробуй оба варианта), где оно точно сработает (/etc/environment, или /etc/profile.d/...).

Добавил MOZ_X11_EGL=0 в /etc/environment, тормоза пропали. Но это слегка костыль. Вроде как он убирает хардварное декодирование видео.
It's time to kick gum and chew ass. And i'm all out of ass.
Ответ
#8
(09.02.2021 14:Feb)ozz Написал: Но это слегка костыль.
Это слегка настройка. Бэкенд в рантайме переключить нельзя.

(09.02.2021 14:Feb)ozz Написал: Вроде как он убирает хардварное декодирование видео.
Разве?
Правила форума
[Новичкам] Как правильно задавать вопросы, чтобы Вам помогли

«Буду бить аккуратно, но сильно!» © Лёлик, х/ф «Бриллиантовая рука»
Ответ
#9
(09.02.2021 15:Feb)mord0d Написал:  
(09.02.2021 14:Feb)ozz Написал: Вроде как он убирает хардварное декодирование видео.
Разве?

Пока ничего не поменялось вроде:
Цитата:
  • Run Firefox with the following environment variable enabled:
    • In Wayland, with
      Код:
      MOZ_ENABLE_WAYLAND=1
      , see #Wayland.
    • In X.org, with
      Код:
      MOZ_X11_EGL=1
      .
It's time to kick gum and chew ass. And i'm all out of ass.
Ответ


Перейти к форуму:


Пользователи, просматривающие эту тему: 1 Гость(ей)